
GEOG357, Lab 4 

Ratios, Indices, and Transforms  
 
Tools used: Raster Calculator and in the Algorithm Librarian:  

SCALE, PCA, PANSHARP, DECORR (VEGINDEX, TASSEL) 

 

Start Catalyst and open your copy of PG20july2023.pix .. display bands 654 in RGB.  

Check your layers: Switch to the files tab and expand the raster layers to check your 

channels and the original bands. Ensure you know what is in each channel, and label any 

as needed. You may need to ask me how to transfer back any layers you’ve lost by 

overwriting them, i.e. any of bands 1-7. 

 

1. Ratios  
 

First we’ll create a NIR/Red ratio CHANNEL … this can be done in three ways: 

a. Tools -> Raster Calculator in Focus – we’ll use this for its general utility 

b. ARI (Image arithmetic) or         c. RTR (ratio).. both in Focus 'Algorithm Library'  

 

use the Tools -> Raster Calculator dropdown  

Check the file is showing: your Landsat 8 (OLI) PG2023 file 

Create model equations by double-clicking on bands, single click on operators- note that 

selection of a band will return % n …  for example    %4 for band 4  

Use the Raster Calculator box for input, using the keyboard does not work the same. 

 

To create the NIR/Red ratio:     (5/4 for OLI sensor) 

Double-click on Band 5, single-click on   /   and double click on band 4 

The expression should read:    %5 / %4 

 

The default is for 8-bit output = integer values only, no decimals; and output ‘Display’ 

Change type to 32-bit real (you should know why !)  

RUN    (hit the 'run' button = the wee man running) 

If you have a suitable image result, check the save button and browse to your 2023 file.  

 

Change tabs from Maps to Files and rename the label to NIR/Red or something like that.  

Note: Doing this in the Maps tab only changes the listing onscreen, and editing it in the 

Calculator box is ineffective                       Switch back to Maps tab. 

 



Q1. What are the minimum and maximum DN values for the ratio ? 

 

Check by viewing the histogram: Layer-> histogram .. click on the histogram to expand 

[be sure to ‘zoom out’ to the whole layer to get a correct measure] 

In general the ratio should highlight vegetation (the difference between NIR and Red) 

and subdue topographic shading. Check by comparing with the colour composite: 

 

‘Flick between the RGB and ratio displays by turning the top layer on and off. 

They are broadly similar but the ratio highlights vegetated versus non-vegetated areas, 

and reduces shadow areas – view the north sides of the eskers that were challenging to 

distinguish from water before in Lab 2. 

 

Very highest values: the lush green of the soccer fields on 15th Ave below Foothills, 

maybe due to artificial watering. There is also a very bright field next to the Fraser River 

near the top: 525700, 5987000. Maybe it’s watered too – someone’s grow-op ?        

 
Unsupervised classification 

Can the ratio help classification as it’s a new ‘uncorrelated’ layer ?    Let’s do a quick try:  

Analysis -> Image classification -> Unsupervised classification –> you could use your 

previous sessions for unsupervised – add a new 16-bit unsigned layer if you need an 

empty one 

- adapt the setup from a previous session, adding this new ratio channel to the inputs 

along with band 654, with an empty 16-bit channel as the output.     

OK     then 

Select isodata and the default parameters and OK 

There is likely little difference as the 3 input bands are 16 bit, while the ratio is 32-bit 

real, with way smaller relative standard deviation / variance, so we need to make them 

comparable, using the SCALE tool in the algorithm librarian. 

 

SCALE 

Check the histograms and data range for the ratio, and bands 4,5,6. A scalar 

multiplication of  ~10,000 might be suitable though we don’t get to specify this.  

Instead we’ll constrain the scaling to a range similar to the range of bands 4-5-6. 

Open the menu for SCALE, input = your ratio channel, Output ports – check viewer-

Grayscale and check/browse to your file 

Input params tab: leave the first 4 options as default;  constrain minimum output gray 

level to 5000 and maximum to 25000; leave scaling function as LINear 

output should be an unsigned 16-bit channel – same as the original bands.  



Go to Log tab and Run (always view the log tab when running a tool)  

Once this is successful, relabel this layer under the Files tab e.g. scaled ratio.   

Now Check the new channel’s histogram: it should have DNs 5000 - 25,000 

This may not quite match the raw band histograms, but close enough ! 

 

Now run the Unsupervised classification again adding this new channel as input along 

with 654, and use the same output channel as last time (overwriting it). 

This time, you should see that the scaled ratio channel has tweaked the classification.  

 
2. Normalised Difference Vegetation Index - NDVI  
 
The NDVI is the most commonly used normalised ratio/ index as a reliable indication of 

vegetation biomass - the formula is as below: 

 

Method 1: Raster Calculator 

 

We will use the raster calculator (RC) to create a NDVI channel:  

(NIR-Red) / (NIR+Red)  

you need the brackets to get the desired result, and must use the RC keypad (not your 

keyboard) to enter both the bands and characters. It can be a tad cumbersome. 

Output first to the viewer – grayscale; if it looks OK, run again - save to your 2023 file. 

 

Method 2: Vegindex – check it out, for your info or your preference ..  

Tools -> Algorithm Librarian -> use the Find box to find VEGINDEX (and do the 3 lines below) 

In the Input params tab, use the dropdown to view: Index to Calculate :   

you can view the choices including NDVI, but we don’t want ALL 27 

You’ll recognise some from lectures and not some others - 

This seems an oddbod tool, as the Input channels are a combo of TM, OLI, MSI 

You would need to expand Input3 (for Red) and tick the Red band and then Input5 for NIR and tick the 

NIR Band. 

Output port at bottom:   tick viewer and browse to your pg2023 file 

Input Params tab: 

Change Sensor to Landat-8 OLI 

Output type: 32-bit real 

Go to Log tab  and Run      (always good to see what is happening …) 

you’d get a new layer, already properly labelled as NDVI 

Which method do you prefer ? Myself I found the vegindex confusing, with many odd indices:   

I don’t mind typing brackets etc.. so I stuck with the Raster Calc. Either way: 

 

Q2a. What are the MIN and Max values of the NDVI layer ? 



Q2b. What is the correlation coefficient (r value) between the NIR/Red ratio and NDVI 

 … it should be high (right-click on filename  -> scatterplot option)  

They MUST both be in your 2023 .pix file to be able to run scatterplot. 

 

 

Q3. what are the NDVI general range of values for (just check a few locations) 

a. coniferous forest          b. Water         c. Deciduous forest 

 

- flip between NDVI and 654 composite displays – you could also display the 654 

composite, but highlight the NDVI in the contents, so that NDVI values show at 

the bottom, while viewing the colour composite … 

 

While we’re at it, we’ll run NDWI (water) to create a layer we will use in next week’s lab 

to map / extract water (next week). 

NDWI = (Green – NIR ) / (Green + NIR) 

Remember Output type should be 32-bit real  

Check Display and review the result. It should highlight the water as highest DNs 

What DN value seems to capture water – click around and also check the histogram. 

Run again and Write to your PG2023 file and relabel using the ‘files’ tab as NDWI 

 

3. Tasseled Cap : TASSEL * 
 
The tasseled cap is a transformation that is often used in ecosystem and habitat studies. 

This operation will produce 3 new data channels equated to brightness, greenness and 

wetness (BGW) – it enables us to reduce reflected 6 input bands to 3 essential ingredients 

 

*However it requires a ‘metadata’ file which has gone missing, so we’ll leave this to a 

later lab – plenty to do with the other sections today. 

 

Tools -> Algorithm Librarian -> Find -> Tassel 

 

Component 1 is Brightness – an average of all the bands 

Component 2 is greenness – the contrast between the visible and NIR 

Component 3 is Wetness – the contrast between the SWIR and VNIR 

 

4. PCA:  PrinciPAL Components Analysis 

 

Like Tassel, PCA attempts to reduce the 7 band reflective dataset into 3 component 

channels, but unlike Tassel, it can produce up to 7 new component channels. 



Display the PCA menu from the Algorithm Librarian 

Input Layers (bands): check all of  1-7 

Output to Viewer-grayscale, RGB and Save to your file 

Input params tab: 

Eigenchannels:  (type) 1,2,3,4         (we only need the first four components) 

Output raster type: 16U 

Report type: LONG 

Report mode: LOG 

Switch to Log Tab and Run 

 

View the image display – top is the composite from the first 3 components – it has more 

information (contrast) than any band composite. Check that off and review the next four 

layers will display in grayscale: PC4, PC3, PC2 and PC1 

 

The report in the Log Tab gives the eigenchannels and eigenvectors (loadings) in the last 

two tables. Usually the first 3 components ‘explain’ >95% of all the image variance, with 

decreasing amounts per component.  

 

4a., what total % of this image is explained by the 3 components ? (look at the table in 

the log tab with headings Eigenchannel-Eigenvalue-Deviation-%%Variance) 

 

4b. From the Eigenvectors of covariance matrix below it, which input band makes the 

largest contribution to the fourth component ? Rows are component channels 1-7; 

columns are the ‘weightings’ for each component from Bands 1-7 

 

You can now repeat the unsupervised classification as you did with the ratio above, but 

this time, use the 3 (or 4) components as input layers; output to an empty layer (add a 16 

bit unsigned layer if you need one) and run an isodata classification. This should look 

(subjectively) better than all previous attempts, as those 3 or 4 layers maximise content. 

 

5. Pansharpening  
 

The higher resolution panchromatic layer is stored separately so that it retains its higher 

resolution (15m). Add it to your display (File-> Open -> pg20july2025pan.pix 

 

It should line up perfectly: you can’t see the higher res. at full view, so zoom in on an 

area of interest e.g. UNBC / your house. Click the top (PAN) layer on / off to see the 

higher res. Promote (move up) the 6-5-4 colour composite to below the Pan layer display 



 

In the tools dropdown -> Algorithm Librarian, find ‘PANSHARP’ 

Input Multispectral Image channels –use the RGB Mapper to display bands 4,3,2 

 

InputRef: Reference Image channels: (you must) use the same 3 bands (4,3,2) 

InputPan: Panchromatic Image channels: pick the Pan file  

Tick Viewer-RGB .. we are only going to display the result, not keep as new layers 

 

Input params: keep all defaults 

Log tab: (to see what it does) and Run 

 

The result should be ‘synthetic’ bands 2,3,4 – possibly in the wrong RGB sequence, so 

use RGB Mapper to switch 234 to 432 in RGB as needed. Click the new RGB off and on 

to see how it compares to the raw 432 composite pixels. Zoom in to see how it has 

created 4 pixels for every pixel in the original image. e.g. look at UNBC 

 

It’s tempting to now try this with bands 654 for higher contrast- technically a bit naughty 

as PAN wavelengths do not cover the NIR/SWIR bands wavelengths– but do it anyway. 

 

Back to the PANSHARP files tab, change 432 to 654 both in the Input and InputRef 

options. No other changes, back to the Log tab and Run 

 

Use RGB mapper again to ensure 654 are in RGB. Enhance / compare with the ‘raw’ 654 

composite - tick off any layers between them in the files listing. It looks funky purple. 

Some researchers classify with these higher resolution layers, but it’s not standard, as the 

original DNs have been altered mainly for better human viewing; but a pansharpened 

image can be useful in visually checking challenging areas e.g. in shadows  

 

6. DECORR 
As shown in lecture, this can be used to enhance contrast between highly correlated 

layers such as the visible bands. Find DECORR in the algorithm librarian. 

Input layers 432 (Red-Green-Blue)  

Viewer:  RGB and also save to your pg2023file 

 

Input params tab: 

Number of eigen layers to save:   3 

Output raster type: 16U 

Log Tab  and Run   

Don’t close the DECORR panel as you need to interpret the results                         

Funky result, use the RGB mapper, to change the channel colours, - switch PC1 and PC3 

 

Q5a: From the Log Tab, what is the %variance explained by eigenchannel 1 ? 

Q5b: What is the r value (correlation) between the new eigenchannels:  

choose any pair from 1-3   (use the scatterplot option to find r ) 

Please submit your answers as .PDF or .TXT (but not .DOC) 


