
Remote Sensing, Fall 2020 

Lab 7:  Feature Extraction 
 

Lab goals  

Satellite images like air photos can be used for manual interpretation, but because they are 

digital, we can use image processing techniques to semi-automatically extract vector features. 

The specific goal in this week's lab is to create vectors for 2-3 class features which you can 

clearly identify and reduce to a manageable number of polygons.  

There are five main steps: 

• Generate a clean layer containing the desired features –a bitmap or raster channel from 

THR or Ratio-Index-Transform or Classification 

• SIEVE to create a manageable number (sieve works only on raster channels) 

• Generate vectors (raster to vector) –RAS2POLY or  BIT2POLY or EXPOLRAS 

• Smooth vectors – SMBOYLE  

• Examine and clean attribute table  - calculate area stats (in Banff Focus or GIS) 

Features to extract:  

• 1. Water  (twice) – PG and Bowron 

• 2. Forests or another class from labs 2 or 3 

• 3. Avalanche slopes – Bowron only 

 

1. Set-up and Thermal 

 

Start  in the usual way with Banff Focus and open your copy of    pg11sept1996.pix 

Change display to 543, stretch .. note you are displaying 3 bands (channels) one each in RGB 

 

Let's get Thermal .. as we just did it in lectures – add Band 6 in grayscale  

Layer->add ->grayscale ->band 6  .. enhance as needed 

Click on RGB Mapper ->Note you are now displaying one band (channel) 3 times in RGB 

Some striping is visible, orthogonal to the scanner direction and especially where DNs are low. 

 

Tick the thermal band on and off to see the relation between the landscape and thermal 

View the histogram for Band 6:  layer-> histogram 

The band has less contrast than other bands, one indicator is the lower standard deviation (SD). 

 

Q1: how does the Thermal band SD compare statistically with the visual and IR bands – use any 

one of 1-3, and 4,5,7 to compare, no need to use all of them. 

 

Q2: view sample Band 6 DN values for Fields, Water, Urban (use the Bowl) and Forest 

Rank them 1-4 Cooler-> warmer, and briefly explain why this is as you would expect. 

 

 



2. Extracting water from PG 1996 multispectral image 

We’ll first use the water bitmap you created in lab2 to generate a vector shapefile for water: 

rivers and lakes. We can directly convert this to a vector layer using algorithm BIT2POLY  
 
First remind yourself what you have in your .pix file 

Files tab: expand and review the bitmaps  

If you can't remember which bitmap is water, display it/them to see: Layer-> add → bitmap 

  

tools-> algorithm library → BIT2POLY 
Input: the bitmap layer number 
Output: viewer and your pix file (click on browse to find your file) 
Params: smooth should be checked        RUN 
 

If you can’t see your new vector lines e.g. if they are blue, right-click on the new polygon layer 

in the display listing and change the colour 
 

Now uncheck the smooth vectors box in parameters and run again, again output to the viewer, 

and your pix file.  Compare the result with the smoothed version to see the effect of the 

smoothing algorithm … 
Zoom in A LOT to view the difference – the ‘staircase’ of pixels has been reduced, not removed 

 
You now have two new vector layers, one smoothed, one not smoothed.  

 

We will use a more sophisticated algorithm to smooth the unsmoothed version, written by Ray 

Boyle, U. Saskatchewan who I met in my first year teaching at U of S in the 1970s. It is called 

SMBOYLE and is found in the Algorithm Library. 

 

 Input your smoothed vector layer, output to viewer and the 1996 pix file. 
Repeat using the unsmoothed vector layer and compare them all  

You might want to ensure they are all labelled so you know which is which 

 

You should find the best result is the last one - NOT smoothed in BIT2POLY but smoothed by 

SMBOYLE. The double-smoothed one has some strange edges and bits lost, while the one 

smoothed only in BIT2POLY is not as rounded as the last one smoothed by SMBOYLE. 

 

Q3: Why is the best result from the Boyle smoothing algorithm when you don't first already 

smooth (with bit2poly) … read the help 'details' in SSBOYLE to find the answer. 

 

 



3. polygon attribute tables 
 

You can’t sieve a bitmap to remove wee bits, only a raster, but we can remove small polygons 

either in GIS or Banff: right-click on the polygon layer label and pick Attribute Manager 
 

The areas may be in square metres as default with UTM coordinates, and if so we can convert to 

hectares or square kilometres to reduce ‘scientific notation’.  
 

Right-click on the Area column heading, select Table definition, change decimal places to 2 and 

display units to hectares.      Apply     OK 

Deselect Area heading – click on it 

 

Now we can remove small polygons the ‘GIS way’. 

Select the Record dropdown, then query by -> example 

 

Edit the statement to read:  Area < 0.5            (=0.5 hectare) 

You MUST edit using the menu provided, not your keyboard – if there isn't an exact 0.5 hectare 

value, click on the nearest value 

Click on Insert         Apply        OK 

 

Now all records are gray highlighted if Area < 0.5 hectare 

Right-click on one that is selected in the left column and pick delete 

 

Layer-> Save as , pick your 1996 pix file and the Polygon Layer 

You have deleted all the wee polygons smaller than 6 pixels / 0.5 hectare 

 

Layer-save as  again and this time scan down a few lines to the ArcGIS shapefile, and save as 

shapefile .. you could name it something like pg1996water.shp and save in your shapefiles 

folder. This can be directly opened in ArcGIS or QGIS – unlike the layer stored in the .pix file. 
 

Click again in the top left column (blank to the left of 'ShapeID', and you should see a summary 

of stats for the water polygons, including total area (sum) for the polygons. But its in hectares – 

change to square kilometres using the method near the top of this section, and you will need to 

click again in that top left corner of the table. The total area for water should be ~20-30 km2.  

 

Layer-> add → vector and select the rivers layer used in Lab 1: 

home/labs/geog357/shapefiles/rivers.shp  

they won't match exactly as the river course has changed – shifting sandbars and the city rivers 

layer is more detailed as it is digitised from high resolution (1 metre pixels) aerial photography. 

 



4. Polygon layer for a land cover class 

Next, we (I mean you) can do a similar process with another land cover class from your (best) 

classification in Lab 2 or 3.  
Layer→ add→ pseudocolor – next – and pick your best (sieved) classification 

Technically your supervised classification in Lab 3 should be superior = fewer scattered pixels. 

In mine, I had two classes (numbered 8 and 9) that between them seemed to cover all the 

coniferous forest and mixed forest respectively 

.Add your classification to the displayed layers:How about yours ?  did you have something 

similar – or perhaps one or two classes that each covered deciduous or fields or urban or 

industrial? Find a good class to extract. 

First we should SIEVE the classification if you haven't already – maybe you did in Lab 3 ? If 

not, do it now, using a 1 hectare filter (12 pixels) minimum size, and record which new 

raster is the sieve channel. 

We can use the EXPOLRAS algorithm to include several steps: Combine two classes, (sieve*) 

and vectorise. Pick your best class(es) for this part- I recommend forested if possible. 

Note it seems to include sieve, but does not include 'donut holes' in a  polygon e.g. small 

clearings inside forest 
 
Tools → Algorithm Librarian -> EXPOLRAS 
Input: your sieved classification channel 
Output: to viewer and your 1996 pix file 
Params: 
Threshold Minimum and Maximum are the two adjacent classes – for me, 8 and 9; if your 

similar classes were not adjacent, then they weren’t that similar !  
If you are only inputting one class, then that number is the min and max. 
Minimum Area:  12 – this is the sieve operation (which may be redundant if done before) 
You now have a polygon layer for these forested or fields  (whichever you picked) – you don’t 

need to remove small polygons as the minimum did this, though you may still find some 

small ‘donut holes’ of non-forest inside the forest etc.. If need be, you can use the method 

for water to remove small polygons. 
 

Smoothing – run SMBOYLE and output to Viewer and your .pix file 
Right-click on the polygon label in the 'maps' tab and open the Attribute manager.  
convert units to square kilometres, and review the total forested (or which class you picked) in 

the same way you did for water above. 
Next, we'll switch to the Bowron Lakes, so a new project. If you want to save this setup, you can 

use File-> Save project  (name it something like pg1996features); this only saves the 

current layers setup – you may first need to remove any temporary (viewer only) layers. 
 



5. To the mountains and Bowron Lakes 

 

File → New Project 

open your 17 August 1992 Bowron Lakes pix file, and optimize display (543), stretch 

 

 

a. Create a bitmap for water, same method as you did for PG water (THR).  

Find the threshold value that separates water, though you will have higher DNs that conflict with 

shadows – just as in PG. Note that we’ll try to solve this in a later lab. It may not work as well as 

for Prince George, and possibly it needs the classification option for a good water layer, but this 

will do for now. 

 

b. algorithm librarian ->   use BITPOLY (convert bitmap to polygon) 

 

Input bitmap: enter the bitmap number from 5a 

Input params: smooth vectors box should NOT be checked 

output on viewer and your Bowron 1992 .pix file 

Run .... how does it look - you may need to check off  the bitmap display to see the lines OR 

change the colour of the lines (right-click on the vector layer name ... colour) 

 

c. SMBOYLE to smooth vectors 

Same process as  for PG in sections 2 and 4 above 

 

d. Vector clean-up 

Right-click the vector layer in the contents, and view the attribute manager. Repeat steps from 3 

above.  Change units this time to kilometres with 4 decimal places. Right-click on the Area 

column heading, select Table definition, change decimal places to 4 and display units to 

kilometres. Click on that top left table spot to get overall stats. 

 

Q4: a. What is the value given for total (sum) of all water ? 

b. How many lakes / polygons are > 1 hectare (1 ha = .01 km2 – but you knew that !?) 

 

Layer-save as - and save as layer in the .pix file and also as an Arcview shapefile.    

Name it  so you know what it is (water) 

− you can also save it using right-click on the polygon layer in the files tab 

 

 

 

 



6. Avalanche slopes 

 
In my job interview for UNBC in 1994, I showed how we used RS to map avalanche slopes in 

Yoho National Park, where they had recently seen several grizzly bear – human conflicts 

due to humans crossing avalanche slopes -their favourite smorgasbord feeding grounds. 
 
These are not as easy to extract as water - nothing is ! 
One assumes they generally have the highest DN values in the NDVI layer.  
Query the NDVI layer from Lab 4 and determine approximate values for av.slopes 
Use THR to check possible minimum threshold values ~  .51, .62, .73 (?)   
You decide … it's likely the most similar cover type is recovering cutblocks 
We’ll have other ways to remove these later  
 
Run THR saving the result to your 1992  .pix file 
 
Run BIT2POLY to convert – save to your 1992 .pix file 
Edit the vector layer as before - change area to hectares, with 1 decimal,  
 
Use the record-> query by -> example option to remove all avalanche slopes less than 2 hectares 
and save the vector segment also to a shapefile (e.g. avslope.shp) 
 
The result may include many cutblocks, which all lie outside the park, and could have been 

excluded in a classification stage, which allows a mask layer e.g. the park boundary. 
 
If you don't already have the Bowron Lakes park boundary – did we get it in Lab 4 ? 

Layer-> add-> vector and browse to /home/labs/geog357/shapefiles/bowron-utm.shp 
[remember to do the final click on the VEC link in the bottom window] 
Once loaded to view,  right-click and also save it to your own shapefiles folder 
 

You can see all cutblocks are neatly outside the Park – of course, it is a park ! 

We can clip our avalanche slopes to just get the ones inside the park 

 
CLIP: Banff clips rasters nicely but not vectors, so open your favourite GIS –  and clip the 

avslope shapefile to the park, using the park boundary shapefile. * see below for quick note 

on slipping in ArcGIS 
 
 

5a. What is the area of all avalanche slopes inside Bowron Lakes Park in square kilometres ?  
b. What is the total number of avalanche polygons ? 

 



CLIP in ArcMap 

 

In Osmotar, start ArcMap (in ArcGIS dropdown) 

 

accept ‘blank map’ default 

 

Add data (yellow + sign) 

 

You may need to ‘connect to folder’ .. yellow folder with + sign - select your geog357 folder 

 

Add  avalanche slopes and the Bowron park boundary (saved to your folder in Banff-Focus) 

 

Select geoprocessing dropdown → Clip 

 

Input:  your avalanche slopes shapefile 

 

Clip features:  park boundary 

 

Output: navigate to your folder and name the file e.g. parkslopes.shp 

 

OK .. and it should run .. and display when done 

 

click off the input slopes file that had been clipped so you can see the new result 

 

To find total area: 

right-click→ open attribute table 

right-click on area heading → statistics …. to see total area (in metres default) 

right-click on area heading →calculate geometry …. to change units to sq. km  

 

OR in Banff focus 

layer-add- vector → your clipped slopes shapefile 

 

- and view the total area in Banff Focus 

 

 

 


