Data Assembling

Data Assembling
Topics:
After gathering spatial data, data assembling and manipulation become a big part of a GIS project. With all the
datasets in place (from previous lab), we can proceed for further data manipulation to make the data better fit our
needs.
1. Examining Datasets
2. Clipping datasets
3. Extracting Features
4. Merging and re-projecting data
5. Working with Raster DEM
6. Using NTS data
Data locations:

L:\labs\geog413\data\assembling

bndy
TRIM
tlake - Lakes
troad - Roads
trivr - River/Streams
tctrl - Contour lines
twtrl - water body
93i-dem25m-utm10.asc
93j- dem25m-utm10.asc

Study boundary (L:\labs\geog413\data\assembling)

fc93j10, fc93j20
fc93i01, fc93i11

Forest coverage data imported from E00 files (previous lab).

TRIM data converted from previous lab are located in your local folder
(conversion/trim). If you do not have them, convert these trim data to shape file
(see previous lab)

Raster DEM in ASCII format (L:\labs\geog413\data\assembling)

Forest coverage files are located in your local conversion directory. If you do
not have these datasets, import them from L:\labs\geog413\data\conversion\

1. Examine datasets


Create a new folder assembling under your geog413 directory.






Open a new map file and add all TRIM layers listed above and bndy to ArcMap.
Rearrange the order of each layer to make most of them visible.
Change the symbol for bndy layer to Hollow symbol.
Change the default data frame Layers to Aleza as all data here are for Aleza Lake Research Forest
Open the properties window of data frame Aleza, set Coordinate System to
NAD_1983_UTM_Zone_10N.




Save the map file as assembling.mxd in your assembling folder.

The bndy defines the study boundary of Aleza Lake research forest area. You probably notice that most datasets
cover larger area than the study boundary
We will clip the datasets with bndy



Examine the properties of each dataset by double-click the dataset in the table of contents.
In the properties window, click Source tab to check the properties

Notice that all TRIM layers and bndy are in NAD83 UTM 10N projection so they are ready to go for clipping
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2. Clipping
We will first clip TRIM data using Aleza Lake study boundary (bndy) as cookie cutter.
trivr, tlake, troad, tctrl, twtrl and bndy are all in UTM10 projection, we can directly clip these datasets with the
bndy
Before precede, we will set working environments to make sure all output data go to the same spot.




Click Geoprocessing->Environments. Expend Workspace and set your local folder
(K:\geog413\assembling) for both Current Workspace and Scratch Workspace
Click Geoprocessing->Geoprocessing Options and remove the check mark beside ‘Enable to turn off
Background Processing’. This will let you see the progress when the tool is running
Make sure you have all extensions enabled by clicking Customize->Extensions. Place a check mark for
each extension (exclude FME and Survey Analyst)



In ArcToolbox, click
Analysis Tools->Extract->CLIP
Input Features
trivr
Clip Feature
bndy
Output Feature Class rivers_clip (your local folder)



Repeat the steps clip the rest of TRIM layers (trivr, tlake, troad, tctrl, twtrl) with bndy as the cookie
cutter and save the output in your assembling folder.
Input Feature
twtrl
tlake
troad
tctrl

Output Feature
water_clip
lakes_clip
roads
contours

Notice that the Feature Type for these datasets is LINE as TRIM data do not come with polygon features. They
are either in line feature or point feature. Some ground features obviously should be a polygon feature such as
lakes. The polygon features can be built up with the outlines.
After clipping, you should have bndy, rivers_clip, lakes_clip, roads, contours, water_clip in your local folder.


Remove all original TRIM datasets (trivr, tlake, troad, tctrl, twtrl) from the table of contents by rightclick on the dataset and choose Remove. Examine each clipped dataset.

3. Extracting Features
Extract Streams and River Banks
Now take a closer look on rivers_clip


Examine the dataset rivers_clip which contains water bodies. Open the attribute table and examine TYPE
field, there are several types of water body:
'Ditch'
'River 'River 'River 'River -

Definite'
Indefinite'
Left Bank'
Right Bank'

"Left Bank" and "Right Bank" are the outlines for big rivers and the rest of lines can be treated as streams. We
will separate these features to form up new datasets


Make attribute selection on rivers_clip with following expression to extract all none river bank features:
"TYPE" <> 'River - Left Bank' AND "TYPE" <> 'River - Right Bank'
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This query will filter out all the features that are not types of river banks




With the selection on, right-click on rivers_clip and choose Data->Export Data
Set ‘Selected Features’ for Export. That means only selected features will be exported.
Set the Output Shapefile to K:\geog413\assembling\streams.shp

Now examine the rest of river lines. The river lines with "River-Left Bank" or "River-Right Bank" type indicate
that these are big rivers and should be formed up as polygon features.


As all the selected features are none river banks, the river banks can be selected by simply switching the
selection. Right-click rivers_clip ->Selection->Switch Selection.



With the selection on, in the ArcToolbox, click
ArcToolbox->Data Management Tools->Features->Feature To Polygon
Input Features:
rivers_clip, bndy (add each)
Output Feature Class: K:\geog413\assembling\rivers.shp

This tool allows you to build polygon features from lines (selectí )
You may notice that we use two layers to form up the polygons: rivers_clip and bndy. If you look at rivers_clip at
edge on both left and right sides, you should see that the two river bank lines are open, not closed. The bndy can
be used to make up this part. Of course, you can manually change/modify the features to make it closed in Editing
mode.


You will have the resulting dataset rivers added to ArcMap.

The resulting dataset rivers will have polygon features from both bndy and the selected features from rivers_clip.
You probably notice that rivers includes rivers and bndy. Some parts of bndy are not rivers. We need to remove
these parts to keep only the river polygons.


Turn on Editor, in Editing mode, set rivers as the editing layer. Delete the parts that are not rivers. Save
the edits and stop editing. The resulting dataset rivers.shp contains the only river polygons.

Build polygon features from lakes_clip
The lakes_clip contains lake outlines which can be used to build up lake polygons
Note: Check the dataset to see if any of them are not closed, especially at edge of the data. If Yes, you can either
turn on the editing mode to close those features or use lakes_clip and bndy together to build polygons (like
above). Otherwise lakes_clip itself is good enough.


Follow the same steps above build polygon features from lakes_clip. Note: there is no need to do any
selection as all lines are lake lines.



Save the final output as lakes in your assembling folder.
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Extract Island and Flood Land
Examine water_clip which contains water related information, such as flood land, island, mash and etc.
Examine the data field CLASS in the attribute table of water_clip. We will extract island and flood land to make a
separated layer for each type of feature class.



Select all Island feature from water_clip and build polygon features. Save the output polygon features as
island in your local folder
Select all Flood Land feature fr2om water_clip and build polygon features. Save the output polygon
features as floodland in your local folder

In the table of content, keep the layers bndy, streams, rivers, lakes, island, floodland, roads, contours and
remove the rest of data layers.


Save the map file

Update Attributes
The spatial operations that modify the spatial locations/geometry do not automatically update the attributes
related to the geometry such as AREA, LENGTH, and PERIMETERS etc. These information need to be updated
manually.
You have the newly created polygon layers lakes, rivers, floodland, and island. It would be nice to know the area
of each polygon. You need to update the AREA






Open the attribute table of lakes. If there is no AREA field, add a new field AREA to store the area value
for each polygon (Note: use FLOAT or DOUBLE data type and give two digits for decimal).
Calculate the AREA with Calculate Geometry.
Calculate the AREA for each polygon layer (rivers, floodland, and island)
In the same way, calculate the LENGTH for the line features (streams, roads).
Save the map.

4. Merging and Re-projecting data
Now we will look at forest coverage data fc93i01, fc93i11, fc93j10, fc93j20 (from your local folder). Forest
coverage data are stored in four separated files and not merged together like the TRIM data,
The next task is to merge all forest coverage datasets together. Merging datasets can be done with Merge tool in
ArcToolbox.


Turn off all layers in the table of content for now.



Add all forest coverage data fc93i01, fc93i11, fc93j10, fc93j20 from your local folder to ArcMap. If you
do not have them in your local folder, import them from L:\labs\geog413\data\conversion



In ArcToolbo, go to Data Management Tools->General->Merge
Input Datasets:
Output Dataset:

fc93i01, fc93i11, fc93j10, fc93j20
fc_merged (in your local folder)

The merged data fc_merged includes all four sheets of forest data


Open the properties window of fc_merged and click Source tab

Notices that the dataset fc_merged is in BC Albers projection which is different from the rest of datasets you have
(UTM 10N). In order to work with other spatial data for later analysis, we need to reproject fc_merged from BC
Albers to UTM 10N.
Two ways to reproject a dataset from one coordinate system to another:
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By exporting data using the coordinate system defined for data frame
By using the PROJECT tool in ArcToolbox

The easiest way to reproject a dataset is by exporting using the coordinate system defined in data frame.

Reproject data by exporting






Right-click on the data frame Aleza and open the Properties window. Click Coordinate System tab.
Make sure the Coordinate System is set to UTM10N. If NOT.
Right-click on fc_merged->Data->Export Data. Make sure the Export is set to ‘All Features’
Set ‘Use the same coordinate system as the data frame’. That will export the data using the same
coordinate system to the data frame.
Set the output feature class to fc_utm_export.shp (in your local folder)

Reproject data using ArcToolbox
You can also reproject a dataset using ArcToolbox


In ArcToolbox:

Data Management Tools-> Projection and Transformation->Feature->Project

Input Dataset:
Input Coordinate System:
Output Dataset:
Output Coordinate System:

fc_merged
NAD_1983_Albers
fc_utm_proj.shp (in your local folder)
NAD_1983_UTM_Zone_10N.

You may notice that once you choose input dataset, the Input Coordinate System is filled up automatically and
grayed out. This information comes from the input data. If the input dataset does not have coordinate system
information available, you need to specify the input coordinate system. Without knowing the input coordinate
system, the system can't perform re-projection operation.


The output dataset fc_utm_proj now is in UTM 10N projection. Examine the properties of the dataset.

You have two identical forest coverage datasets in UTM 10N projection. You can keep one for analysis and
remove the other one.


Keep the fc_utm_proj.shp for later use. Remove fc_utm_export.shp from the table of contents

With forest coverage data merged and reprojected, we can clip the forest coverage data with bndy to make it fit
into study boundary


Use bndy as a cookie cutter, clip fc_utm_proj.shp and save the output as fc.shp in your local folder.



Now remove all the reset of forest coverage data fc93i01, fc93i11, fc93j10, fc93j20, fc_merged,
fc_utm_export.shp, fc_utm_proj.shp from the table of contents

You should have following layers in the table of contents:
bndy, streams, roads, contours , rivers, lakes, island, floodland, fc
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5. Working with raster DEM
DEM (Digital Elevation Model) information is required for our analysis.
We have a dataset contour line (contours) from the TRIM layer with 20 meters interval and two DEM sheets (93i
and 93j) stored in ASCII format at 250000 scale. Both data sources can be used to create a raster DEM.

Create a raster DEM from contour lines (contours)


In ArcToolbox: 3D Analyst Tools->Raster Interpolation->Topo to Raster
Input Feature:
contours
Field:
ELEVATION
Type:
Contour
Output raster:
dem_cont (your local assembling folder)
Cell size
25

The resulting raster dem_cont will have 25 meters resolution

Creating a raster DEM from ASCII file
We have another data source 93i-dem25m-utm10.asc and 93j- dem25m-utm10.asc stored in ASCII format
containing x,y,z value. The data source can be converted to raster DEM.
As the working area is across two 250000 scale map sheets, we will need two DEM mapsheets (93i and 93j) to
cover the area.
To do the conversion, ASCII to Raster tool will be used to convert ASCII file to raster DEM.




In ArcToolbox: Conversion Tools->To Raster->ASCII to Raster
Input ASCII file:
L:\labs\geog413\data\assembling\93i-dem25m-utm10.asc
Output Raster:
93i_dem (in your local folder)
In the same way convert 93j-dem25m-utm10.asc and save the output as 93j_dem in your local folder

Merging Raster
Now with two raster DEMs, we will merge/mosaic them together


In ArcToolbox: Data Management Tools->Raster->Raster Dataset->Mosaic to New Raster
Input Raster:
93i_dem and 93j_dem
Output Location:
K:\geog413\assembling (your local)
Raster Dataset Name: 93ij_dem
Number of Bands:
1



Click OK. Check the properties of this dataset by right-click on it and open the properties->Source
If the coordinate system (Spatial Reference) of 93ij_dem is not defined, define the coordinate system to
UTM10N in ArcCatalog by clicking the Edit button right beside and define the coordinate system to
UTM 10N (Note: you need to remove datasets from ArcMap first)



Clipping Raster
As the 93ij_dem covers way larger area than study boundary, you will need to clip this raster to make it fit into
study area.


In ArcToolbox: Data Management Tools -> Raster -> Raster Processing ->CLIP
Input Raster:
93ij_dem
Output Extent: bndy
Output Raster: dem (in your local folder)
Examine the output raster dem.
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Now you have two raster DEMs dem_cont created from contour line and dem generated from ASCII file.
Examine two datasets and use one of them for later analysis. Either datasets will work fine.



Keep one raster DEM (dem) and remove the rest of raster DEM layers
Save the map file in your local folder.

Now the spatial datasets including trim data, forest coverage, boundary and DEM are ready for analysis.
Clean up your working directory and delete the temporary datasets you do not need, especially the raster
datasets (93i_dem, 93j_dem and 93ij_dem) and forest coverage data

~~~~~~~~~~~~~~ The End ~~~~~~~~~~~~~~
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