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1. Introduction
A digital elevation model (DEM) is a digital representation of ground surface topography or terrain. It is also
known as a digital terrain model (DTM). A DEM can be represented as a raster (a grid of squares) or as a
triangular irregular network.
Raster surfaces / Raster DEM (Digital Elevation Model)
Raster DEM represent a surface as a regular grid of locations with sampled or interpolated values. A grid consists
of a rectangular array of uniformly spaced cells with z-values. The smaller the cells are, the greater the locational
precision of the grid. The example below compares a higher precision grid (left) to a lower precision grid (right).

DEMs (Digital Elevation Model) provide one of the most visual and dynamic portions of GIS, since topography is
both continuously varying and multi-faceted. Hence you can produce themes for GIS analysis that have multiple
attributes and can be used to produce highly visual images.

2. Creating a Raster DEM
Two major types of vector data are used for building surface data. Mass points with an elevation value attached
to each point or contour line in which each line represents an elevation isoline. All vertices along the line have the
same elevation value.
In a raster DEM, each pixel value represents the elevation of the location. A Raster DEM can be generated from
ASCII text file containing xyz values or vector data with elevation information in the attribute table (dem points,
contours etc).



Create a new folder surface under your geog300 folder
Start ArcMap with a new ArcMap file. Enable 3D and Spatial Analyst extensions by clicking Customize>Extensions and place a check mark beside 3D Analyst and Spatial Analyst. Close the window.

Create a raster DEM from contour lines / DEM points
First we will set up working environment for running ArcTools
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Click Geoprocessing->Environments from top menu. Expand Worksapce and set the Current Workspace
to K:\geog300\surface.
Disable background processing by clicking Geoprocessing->Geoprocessing Options, remove the check
mark beside Enable under Background Processing.
Add dempoint_trim, unbc_cont5 from L:\labs\geog300\unbc_dem to ArcMap
Open the attribute table of unbc_cont5 and examine the field ELEVATION. The values in this field are the
elevation of each contour line, which will be used in creating the raster surface.
In ArcToolbox, click 3D Analyst Tools->Raster Interpolation->Topo to Raster
Input Feature:
unbc_cont5
Field:
ELEVATION
Type:
Contour
Output surface raster: cont5_dem (in your local DEM folder)
Output cell size:
25
Click OK

The output raster cont5_dem will be generated in your local folder and added to ArcMap.
Point elevation data can be also used for DEM creation





Right-click dempoint_trim and open the Properties window.
Click on Fields tab. There are many data fields we do not need. We can hide these fields and just show
the information we need. Uncheck all check-box except FID, Shape, and ELEVATION fields to show the
three fields. Close the properties window.
Now in the same way create a raster DEM using dempoint_trim with Type set to PointElevation and Size
to 25. Save the output as point_dem in your local folder.

You can use both contour lines and elevation points to create a better and more accurate surface. In general,
more information (elevation) are added, the better surface would be.






Run Topo to Raster tool from ArcToolbox
Add dempoint_trim and unbc_cont5 form the dropdown list for Input Feature
Set Elevation to Field for both datasets, set PointElevation Type for dempoint_trim and Contour for
unbc_cont5
Give the output raster to cp_dem in your local folder.
Set cell size to 25 and click OK.

Create a raster DEM from ASCII file
Raster DEM can be created from an ASCII file


In ArcToolbox, click Conversions->To Raster->ASCII to Raster
Input ASCII raster file:
L:\labs\geog300\unbc_dem\unbc_dem.asc
Output raster:
K:\geog300\surface\asc_dem
Output data type:
INTEGER

The output data type is set to INTEGER. That means the output cell values are integer type (whole number). A
VAT table (Value Attribute Table) will be created for integer type of raster. You can also choose FLOAT to give the
decimal value for each cell. The FLOAT type of raster (continuous data) does not have VAT table and take more
disk space.
 Click OK. The new raster DEM asc_dem will be created and added to ArcMap.
 Examine the cell values of asc_dem. As the cell values are integer type, an attribute table VAT was
automatically generated. Open the attribute table and you can find elevation values in VALUE field and
the number of cell with the value in COUNT field
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So far four surface datasets have been created: cont5_dem, point_dem, cp_dem, asc_dem. Examine the range
values for each DEM dataset, you might find that the values are slightly different. Why?


For comparison, change the symbology and choose the colour ramp to match the other three DEMs.

3. Examine Lidar DEM
In this section, we will examine a DEM created from Lidar data.
LIDAR (Light Detection And Ranging) is an optical remote sensing technology that uses laser pulses to find range
and/or other information of a distant target. Like radar technology, which uses radio waves, the range to an
object is determined by measuring the time delay between transmission of a pulse and detection of the reflected
signal. LIDAR DEMs typically have very high resolution and are used for example in archaeology, geomorphology,
hydrology and forestry etc.




Turn off all layers except cp_dem and add lidar_dem and lidar_hsd from L:\labs\geog300\unbc\lidar.
The lidar_dem is the DEM created from lidar data with one meter resolution. The lidar_hsd is the
hillshade created from the lidar_dem
Zoom in on the UNBC area, display the hillshade on top. With Identify tool, query the elevation layer to
view values down the agora steps – you might be able to see individual steps. Compare these elevation
values with those in the same location from the cp_dem created in the last section.

Examine the LiDAR values also around the two detention ponds, and compare the extra details with the other
(coarser) DEM.
In the east portion of the LiDAR DEM, you can see the parallel ridges that are beach lines from Glacial Lake Prince
George created 10,000 years ago by a proglacial lake ponded up by retreating ice. The ridges run mostly N-S and
are visible to the north of campus and southeast across the road from the Sports Centre.
Due the high density of LiDAR points, the DSM (Digital Surface Model) can be built from LiDAR points and then
the canopy height can be calculated by subtracting the base earth DEM from DSM. Let’s take a look how the
canopy looks like.




Add lidar_dsm from L:\labs\geog300\unbc\lidar folder
In ArcToolbox, Spatial Analyst Tool->Map Algebra->Raster Calculator
Build the following express
“lidar_dsm” – “lidar_dem”



Save the output raster as lidar_canopy in your local folder.

You may notice that there are some negative values in lidar_canopy due to data error. These area should be 0
(like lake area). To eliminate the negative value, use Raster Calculator to remove the negative value with the
following expression
Con("lidar_canopy" >= 0, "lidar_canopy", 0)



Save the result as final_canopy. Examine final_canopy

4. Deriving secondary surface products
Just looking at 3D data is not enough. We often need to query data or derive secondary spatial information from
the surface. For example slope, aspect etc.
3D Analyst provides you with tools that allow quantitative analysis of the shape of a surface such as creating
contour lines, slopes which is often used in analysis to find the areas with low slopes for construction or areas
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with high slopes, which may be prone to erosion or landslide and aspect information which used to determine
how much sun a slope will receive - for instance, to model how vegetation will grow or snow will melt, or how
much solar heating a building will receive.
In this part of lab, you will be exploring tools and functions to get secondary surface information.
Slope identifies the steepest downhill slope for a location on a surface. The
Slope command takes an input surface data and calculates an output raster
containing the slope of each cell. The lower the slope value is, the flatter the
terrain is; the higher the slope value is, the steeper the terrain.

Calculating average slope
Later in the lab, you will see how GIS can be used to create slope values across a surface, but here you will
manually calculate slope using the difference in elevations between two points and the distance between them:
Average Slope (percent) = 100 * vertical rise / horizontal run
Average Slope (degree) = Inv tan (vertical rise / horizontal run)

The measurement of vertical rise and horizontal run must be in the same units or you have to convert one. On a
hardcopy map, we would calculate vertical rise from the difference in contour heights, and the horizontal run,
given by measuring the distance with a ruler (and converting to actual ground distances).



Open a new empty map file and add creeks and lakes from L:\labs\geog300\unbc and unbc_cont5 from
L:\labs\geog300\unbc_dem
Examine creeks, lakes. unbc_cont5. There is only small stream running into Shane Lake (south-west area
of the lake near 510674, 5971143), query the highest and lowest contour lines it crosses, this should be =
825m / 815m - and assume the lake surface is 1 meter lower at 814m. The distance using the measuring
tool

comes to about: 125m. The heights and the distance are both in meters.
Vertical Rise = 825 – 814 = 11m,
Horizontal Run = 125m
Slope (percent%) = 11 / 125 * 100 = ~8.8%

To convert slope to degrees: Calculate using the inverse tangent of height change / distance. Use the computer
calculator: Start->All Programs -> Accessories -> calculator, Click View -> Scientific.
In this example:

slope (degree) = Inv Tan (10 / 125) = ~ 5°

Deriving slope raster from surface
Sometimes the elevation of a point on a surface is less interesting than the slope of the surface at that point. To
get this information, you can derive a new raster that shows the slope of the surface. Slope is rapidly calculated
for each triangle face in a TIN or a raster DEM pixel.
The raster dem will be used as the surface data.



Aadd dem from L:\labs\geog300\unbc
In ArcToolbox, click 3D Analyst Tools->Raster Surface->Slope
Input Raster:
dem
Output Raster:
K:\geog300\surface\slope
Output Measurement:
Degree




Leave the z-factor as it is
Click OK. The output slope raster will have the same resolution as dem (5 meters). Query cell value with
Identify button to find the slope value.
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Deriving Aspect from surface
Aspect is the direction that a slope faces. It identifies the steepest down slope direction at a location on a surface.
It can be thought of as slope direction or the compass direction a hill faces. Aspect is calculated for each triangle
in TINs and for each cell in raster.
Aspect is measured clockwise in degrees from 0 (due north) to 360 (again due
north, coming full circle). The value of each cell in an aspect grid indicates the
direction in which the cell's slope faces. Flat slopes have no direction and are
given a value of -1.



Turn off the slope
In ArcToolbox, click 3D Analyst Tools->Raster Surface->Aspect
Input Raster: dem
Output Raster: K:\geog300\surface\aspect



Click OK. The output aspect raster will have the same resolution as dem (5 meters).
Add lookouts from unbc folder if necessary. What is the slope and aspect respectively at the western
lookout?

Deriving a hillshade of a surface
Hillshade shows the hypothetical illumination of a surface, given a specified light source. Hillshade can be used to
analyze the intensity and duration of sunlight received at a location on a surface. They are also used in
conjunction with elevation layers to give depth to terrain maps.
The hillshade function obtains the hypothetical illumination of a surface by determining illumination values for
each cell in an elevation grid. It does this by evaluating the relationship between the position of the light source
and the direction and steepness of the terrain. By default, shadow and light are shades of gray associated with
integers from 0 to 255 (increasing from black to white).
Creating a hillshade raster





Turn of slope and aspect
In ArcToolbox, click 3D Analyst Tools->Raster Surface->Hillshade
Input Raster
dem
Output Raster:
K:\geog300\surface\hillshade, Take the default for Azimuth and altitude
Click OK

5. Mapping contours
Contour lines are a familiar way of representing surfaces on maps. A contour is a line through all contiguous
points with equal height (or other) values. The distribution of the lines shows how the values change across a
surface. Where there is little change in a value, the lines are spaced far apart. Where the values rise or fall
rapidly, the lines are close together. By following the line of a particular contour, you can identify which locations
have the same value. By looking at the spacing of adjacent contours, you can have a general impression of the
gradation of values.

Deriving contours from a surface
You can create contour lines for a whole surface, or you can click a point and create a single contour that passes
through it.
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In ArcToolbox, click
Input Raster:
Output Line Feature:
Contour Interval:
Click OK

DEM & Surface Analysis

3D Analyst Tools->Raster Surface->Contour
dem
K:\geog300\surface\cont5
5

The output contour line feature cont5 will have elevation value stored in CONTOUR field. Examine the contours
lines and the interval with Identify tool or in the attribute table.

6. Viewshed
Viewshed identifies the cells in an input raster that can be seen from one or more observation points or lines.
Each cell in the output raster receives a value that indicates how many observer points can be seen from each
location. If you have only one observer point, each cell that can see that observer point is given a value of one. All
cells that cannot see the observer point are given a value of zero. The observer points feature class can contain
points or lines. The nodes and vertices of lines will be used as observation points.
Viewshed is useful when you want to know how visible objects might be—for example, from which locations on
the landscape will the water towers be visible if they are placed in this location? Or what will the view be from
this road?
Assume these sample locations are treated as lookout locations; we want to know which area can be seen from
these lookout locations
 Add samples from L:\labs\geog300\unbc
 First we will set raster working environment for this operation
 Go to Geoprocessing->Environments and set the environments as the following:
Current Workspace:
your local folder
Scratch Workspace:
your local folder
Processing extent:
same as dem
Raster Analysis – Cell size:
same as dem
 First we will change the Primary Display field and the Label field for samples. Double click samples to
open the properties window.




Click Field tab and choose ID from the dropdown list for the Primary Display Field. Click Label tab and
choose ID for the Label field. Click OK.
In ArcToolbox, click the Spatial Analyst->Surface ->Viewshed
Set the parameter as the following:
Input Raster:
dem
Input point:
samples
Output Raster: K:\geog300\surface\samples_vsd



Leave everything else as they are and click OK to generate the new raster.



Open the attribute table of samples_vsd. The VALUE field indicates the number times a cell can be seen
and the COUNT field tells you that the total number of cells that can be seen
Examine the last record; the total number of cells that can be seen 3 times is 1719.



Examine the first record; the value in VALUE field is 0. That means 1023968 (COUNT)cells can't be seen by any of
these point locations.
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7. Extracting elevation values for points location
Sometime you may want to know the elevation at certain location(point features). This can be easily done by
running a tool Extract Values to Points. We will do an elevation extraction to samples



In ArcToolbox, click Spatial Analyst Tool->Extraction->Extract Values to Points
Set the parameter as the followings:
Input point features:
samples
Input raster (surface data):
dem
Output point features:
samples_elev.shp



Open the attribute table of smaples_elev.shp and examine the field RASTERVALU. This is the field added
by running the tool and the field values are the elevation from the Input raster(dem)

8. 3D visualization
Viewing data in three dimensions gives you new perspectives. 3D viewing can provide insights that would not be
readily apparent from a planimetric map of the same data. For example, instead of inferring the presence of a
valley from the configuration of contour lines, you can actually see the valley and perceive the difference in
height between the valley floor and a ridge. ArcScene application is the core of the 3D Analyst extension.

Start ArcScene







Start ArcScene by clicking Start->All Programs->ArcGIS->ArcScene
If the table of contents does not show up, Click Window->Table of Contents
Add the dem from L:\labs\geog300\unbc
Right-click dem and open the properties window. Click the Base Height tab and click the radio button
beside ‘Floating custom surface’ and choose dem from the dropdown list. This will use the elevation in
dem as the ground height. Click OK
Use the 3D navigation button and view buttons to see the surface from different points of view.

The area looks pretty flat. Let's do a bit of changes to make more contrast on elevation.

Setting Scene Properties




Right-click Scene Layers in the table of contents and choose Scene Properties
Type in 3 or 5 for Vertical Exaggeration. This will result in more contrast on elevation.
Using 3D navigation button and view buttons to see the surface from different view again. You can now
clearly tell which location is lower or higher.

Draping contours and 2D data on surface
Contours are a familiar surface representation for many people, and they have many uses in a scene. You can
display contour features in a 3D scene by setting the base height of the contours from their value in the feature
table. Contours in a scene can enhance terrain visualization. The example below shows contours superimposed
on terrain surface model.
 Change the symbology of dem to a color schema (elevation color)
 Add unbc_cont5 from L:\labs\geog300\unbc_dem
 Right-click unbc_cont5 and choose Properties. Click the Base Heights tab
 Click the Base Height tab. Click the radio button beside ‘Floating custom surface’ and choose dem from
the dropdown list. This will use the dem as the ground height. Click OK
You can drape 2D data on the surface to make a 3D effect.
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Turn off unbc_cont5 layer. Add data creeks from L:\labs\geog300\unbc to ArcScene.
In the same way drape creeks on the surface

Draping an image on the top of surface





Turn off all layers in the table of contents
Add image campus50cm_2010 from L:\labs\geog300\unbc
Add data unbc_campus_features, and unbc_campus_roads from
L:\labs\geog300\unbc\campus_digitizing
Move the unbc_campus_features, and unbc_campus_roads above campus50cm_2010

Rearrange theses layers to make them all visible.



Set based height to dem for image layer campus50cm_2010 and choose Properties.
Set Base Height to dem for unbc_campus_features, and unbc_campus_roads respectively and change
the layers to appropriate symbols.

Extruding the features in a layer
A 2D feature can be extruded in 3D view, such as building height.
 Open the properties of unbc_campus_features and click the Extrusion tab. Place a check box to extrude
the features
 Click the button right to ‘Extrusion Values or Expression’ and double click Height_ft in the field list to set
the Extrusion Values. This will result the building footprint to stand up to the height specified in the field
Height_ft.



Click OK. The features are extruded and stand up from the ground.



You can save the ArcScene file to your local folder.

Assignment 6: Surface analysis (5%) due next week Oct.23, 24, 25
In this assignment, you will perform a surface analysis for Forest for the World area
Data: L:\labs\geog300\unbc:
dem, lookouts, lakes, trails, ffw_bndy




Extract elevation, slope, and aspect value for each lookout location.
Calculate the average slope from east to west lookout
Generate a viewshed with lookout as the observer locations

1. Copy lookouts from L drive to your local folder. Use your local copy for this assignment.
2. With Extract Multi Values for Points tool in ArcToolbox (Spatial Analyst->Extraction->Extract Multi Values
to Points), extract dem, slope, aspect (generated in this lab) values for each lookout location. Add all
three rasters for the Input Raster. You will have three raster values from inputs for each lookout location.
Note: this tool does not generate a new point layer as you did in the lab with Extract Values for Points
tool instead the raster values will be added into the input point features (lookouts, your local copy).
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Check the attribute table of lookouts. What elevation, slope and aspect are for each lookout
respectively?
With elevation value extracted for each lookout location, calculate average slope in percent from west to
east lookout (show your work)
Set processing extent to ffw_bndy and cell size same as dem. Generate a viewshed for the Forest For the
world area with lookouts as the observer locations.
Clip lakes, trails with ffw_bndy and save them as lakes_ffw, trails_ffw respectively
Make a simple map showing the viewshed symbolized based on the number of times visible from the
lookouts together with lookouts, lakes_ffw, and trails_ffw. The map should be well layout and with
proper title, legend, scale and your name. Export the map to a JPG or PNG image

Deliverable:




Make a title page with the course name, assignment number, your lab session, your name and studentID.
Answers for 2, 3, and a map from step 6. Insert the map from step 6
Save the file as lastname_firstname_geog3002018_A6. Email the file to your TA with subject Geog300 A5

NOTE: Please name the file correctly (lastname_firstname_geog3002018_A6)
Assignment is due next week (Oct.23, 24, 25). NO late assignment is accepted

~~~~~~~~~~~~~~~ The End ~~~~~~~~~~~~~~~
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