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Assignment 1

1. Login and Getting Started
Before doing any work in GIS lab, make sure you have a GIS user account setup.
For this course, we use Linux system as the client machine to connect windows terminal server to run GIS
software.



To login into the GIS lab computer, use your UNBC UNI credentials. It might take a while to load system.
Once logged in, you should see application icons listed on the desktop. If this is your first time to work in
GIS lab, you probably do not have these icons. If this is the case, logout from the computer (lower left
menu button) and then login again, the icons should show up on the desktop.

Starting Windows Terminal Server
The software we will use for this course is ArcGIS running on windows terminal server OSMOTAR.
 Find the icon Osmotar – Terminal Server on your desktop and click it. This will establish a remote desktop
connection to Windows Terminal Server OSMOTAR.
 A window will pop up to allow you to login to windows environment. Click your username to login. If your
username is not showing, click Other User.
 Login with your UNBC UNI account. If you have problems to login, consult your lab instructor.
In OSMOTAR terminal server window


Click Start-> This PC. Here you will find local drives and network drives. The following network drives are
important.
Network Drives Description
Usage




K:

GISFS2-username

Your home directory for files and data storage (full access)

L:

GISFS2-Home

GIS file storage home for all users and labs (read only)

K drive is the user's home directory with full access. You will save everything here
L drive is the home for all users. The folder "labs" on L drive holds all lab data for the courses running in
GIS lab. This drive is read only.

NOTE: DO NOT save anything on C drive and your desktop. C drive is cleaned up periodically
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2. Connecting to data source (working directory)
ArcGIS is the main software used in this course. ArcGIS is designed and developed by ESRI (Environmental Systems
Research Institute) to work on spatial data and analysis. ArcGIS is a package of GIS software. It includes a set of
applications for working with GIS. For more information about ArcGIS, please visit ESRI website at
http://www.esri.com.
Two major applications you will be using frequently in ArcGIS: ArcCatalog and ArcMap. ArcCatalog is an
application for browsing, organizing, distributing, and documenting spatial data, while ArcMap is mainly for data
display, query, analysis and map making.
To start ArcCatalog


Click Start->All Programs->ArcGIS->ArcCatalog

The catalog tree at left is for browsing and organizing your data. The contents of the items highlighted in the
catalog tree are displayed in the main window at right. The Contents, Preview, and Description tabs let you view
the data in different ways. You will see this later.
ArcCatalog lets you set up connections to data sources, which may reside in a folder on a local disk or a database
on the network. This helps you to locate the information quickly. All the data used for this course are located at
GIS file storage and all data created from the lab exercises will be saved on GIS file storage as well.
Two locations are important. The K:\ drive is users’ home directory for storing all user’s data and the L:\labs
folder holds all course data. We will create two connections to point to these locations for data access.
First create connection K:\ for data saving


Find icon button
on the tool bar at top. Click on this button to connect a location. In the popped
window, find K:\ drive and click OK. You will see a new connection K:\ displayed and highlighted in
ArcCatalog tree. This connection links to your home directory on GIS file storage

Now make a connection to L:\labs folder



Click
button. Find L:\ in the popped up window. Click the plus sign beside the L:\.
Scroll down to find labs folder and click it. Click OK. A connection to L:\labs displayed and highlighted in
the catalog tree. The contents of labs folder can be displayed by clicking the plus sign beside the L:\labs\
in the Catalog tree. You can click any item here to see more information on dataset at right window.

The data connection can be removed by highlight it and click Disconnect button at top toolbar
button) to speed up the loading time.

(the third

Now take a look at UNBC datasets. A folder called unbc under L:\labs\geog300 contains all datasets related to the
UNBC area.




Scroll down to find the unbc folder under L:\labs\geog300. Click the plus sign beside to list its contents.
Click the dataset boundary in the catalog tree. boundary is a polygon feature in shapefile format that
contains UNBC reserve land and Forest For the World.
Click on Contents tab in the right window. This tab displays the content of the item highlighted at catalog
tree, the name of feature, the type of feature class and the thumbnail if there is any.



Click Preview tab. The Preview window lets you preview the dataset geographically and its attributes. The
boundary is displayed with solid filled color.



The Description window provides you all the description about the dataset highlighted at left. You can
also document the spatial data here.

UNBC

2018

~2~

GEOG300

Introduction to GIS

The data can be viewed geographically or by attribute table. Each spatial feature has a corresponding record in
the attribute table. The attribute table contains details on each spatial feature in the dataset, such as area,
perimeter, length, name and other none spatial information etc.


Click on Preview tab in right window. A dropdown list called Preview is located at bottom of the right
window. It allows you to choose how to view the data. Click the dropdown list right to Preview and
choose Table. The content of the table associated with the dataset is displayed. Here you can find the
total number of records (features) from the bottom part of the window and you can navigate among the
records with the navigation buttons at bottom (in red square). This dataset has three records.

The table can be sorted the based on attributes. For example, we want to know which polygon has the largest
area. We can sort the AREA in descending order and the record listed at top will be the largest polygon.


To sort the AREA in descending order, right-click on the column header AREA and choose Sort
Descending. After sorting the table, you will have the record with largest area listed at top.

Each spatial dataset has properties such as area extent, attribute field description, coordinate system etc. The
properties of a spatial dataset can be found by right-click on the dataset and choose Properties




Right-click on boundary and choose Properties. A window pops up showing all meta information about
the dataset (image above)
Click on XY Coordinate System. Here you can find the projection and coordinate system of the dataset
Repeat the steps to examine trails, lakes, and soilplots under UNBC folder.

3. Zoom, Pan, and Identity
ArcCatalog allows you navigating among the spatial data, finding the detailed information from attribute table
and creating thumbnails on spatial dataset etc. You should see the following toolbar in ArcCatalog window. If you
do not see it, click Customize->Toolbars->Geography from the top menu to turn it on.
The first and second buttons are zoom tools allowing you to zoom in and out.
The third one is the Pan tool for moving data display around. The fourth button
allows you to bring all features into the display area. The two arrows button allow you to go to previous extend or
next. The ( i ) button is the Identity tool that you can use to query the spatial data and the last button on the tool
bar creates a thumbnail on spatial data (do not use this button for the data sitting in labs folder, as you do not
have permission to change and modify the data).
Play around with these buttons with UNBC datasets.


UNBC
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Highlight the trails in the catalog tree. The trails are displayed in right window. Click Zoom In button (first
button) then hold down the left mouse button to draw a rectangle around the area of interest. You can
also just click a place to zoom in OR out. Try the Zoom out button to see the changes.
The Pan button is for moving around. Click the Pan button and place the mouse cursor to display area.
Hold the left mouse button while moving the mouse to move around in the display window.

The Identify button
allows you to see more details (attributes) of a spatial feature. Click on Identify button
and click any trails line in the display window. An Identify Results window pops up showing all the details on the
trails segment you just clicked.

4. Managing data with ArcCatalog
ArcCatalog allows you to perform data management tasks, such as create, delete, copy and paste a file, a spatial
dataset or a folder etc. As you need a place to hold all data and files you will create in this course, it would be
good to create a folder something like geog300 under your home directory on GIS file server to store the datasets
and files for this course.
Make sure you have the network drive K:\ (your home directory) and L:\ drive for GIS home


Right-click on K:\ and choose New->Folder. Type geog300 and hit the Enter key. Now you should have a
new empty folder geog300.

NOTE: Do NOT to use spaces for the name of file, folder, and dataset. This may cause problem sometimes when
you work with spatial dataset


As you will complete a number of labs and project for this course, it would be a good idea to have a folder
for each lab to better organize your data. For this first lab, create a folder under geog300 and call it
intro_gis

5. Using ArcMap
ArcMap is the main application for data display, query, analysis and map output.

What you can do with ArcMap






Explore the data source (spatial and non-spatial)
Analyze data
Present results
Customize the interface
Programming

Starting ArcMap



Click Start -> All Programs -> ArcGIS -> ArcMap
When ArcMap starts, a dialog appears, here you can decide how you want to start ArcMap. Double click
‘Browse for more..’ from the left. This will open an existing map file.

Navigate to L:\labs\geog300\esri_canada\ and choose canada.mxd. Click Open. A map is displayed in the right
part of the window and a list of layers is displayed in the table of contents at left. This map file contains
information about Canada.
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Several things are important to know about ArcMap
Map Files: Whenever you work in ArcMap, you are working with a map document. A map document has file
extension .mxd. Everything you added into ArcMap can be saved into a map file. Symbology(colors, symbols,
pattern etc.), labelling, map layout, layer information etc. are saved into map file as well. You can open the file
later whenever needed.
Data Frame: ArcMap organizes datasets into data frames. Each data frame contains datasets made of shape files,
grids, coverages, or geodatabase, to spatially register with one another, these datasets should usually be based
on the same coordinate system. If one or more of the datasets in a data frame do not have projection information
or have different coordinate system, ArcMap will display a warning message. By default, ArcMap use the first
available projection information (usually the first dataset with coordinate system info you add into ArcMap) for
data display.
Toolbar: Associated with ArcMap is a tool bar, which includes such tools as Zoom in, Zoom out, Pan, Select
Elements, and Identify. When you hold the mouse point over a tool (a graphic icon), a short message called a Tool
Tip appears in a floating yellow box to tell you the function of the tool. These tools have the same functionality as
in ArcCatalog. Try it.
View Mode: ArcMap has two views: Data View and Layout View. (The buttons for the two views are located at
the bottom of the view window.) Data View is for viewing, querying, and manipulating data, while Layout View is
for designing and layout the map output for printing and plotting.
Layers in ArcMap. A spatial dataset in ArcGIS is a GIS "layer." A data layer is composed of a particular geographic
dataset embedded into a single spatial data model. A layer may contain only one type of data, for example, point
data
Map Document

Scale

Toolbar
Data Frame

Layer
s

Coordinates

Data View

Layout View

Layers can be added and removed from a map file. All layers, once added, will appear in the view with default
symbols. These symbols can be manipulated in a variety of ways to improve cartographic visualization.
The Table of Contents: The table of contents at left lists all layers added into ArcMap. A box with +/- sign beside
each layer allows you to show/hide the Symbology of a layer. A check box beside each layer allows you to toggle a
layer on/off.
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6. The order of data Layers
The map file canada.mxd you just loaded contains information about Canada including water bodies, major
roads, provinces, major cities, rail roads, national and provincial parks.
In the table of contents, each data layer comes with default symbols (points, lines, polygons) chosen randomly by
the system based on the feature type. The marker symbol usually is used to represent point feature, the line
symbol represents line feature and the rectangle with filled solid color represents polygon feature.
Now take a closer look at each data layer.


Click the check box beside Major Roads layer to turn it on if necessary.
Can you see the major roads layer on the map (purple line)? No, this is because layers in ArcMap are drawn in the
order from bottom to top in the table of contents. In another word, the bottom layer is drawn first and then the
second layer from the bottom and so on so far. The Major Roads layer is located below the Province layer. It was
drawn first and then the Province layer is drawn after on the top of the layers located below it. The Major Roads
layer is covered up by the polygon layer Province (filled with solid color).






Now change the order of these layers to make most data layers visible on the map. Click and hold the left
mouse button on Major Roads and drag it above the Province layer. You will see a black bar showing up
when dragging a layer. Release the mouse button when you see the black bar showing above Province
layer. Can you see the Major Roads layer displayed on the map?
Rearrange the order of layers to make them in the order: Major Cities, Railways, Major Roads, Provincial
Park, National Park, Province, Water from top to bottom in the table of contents. Now you should be
able to see most of layers.
Toggle the check mark beside each layer to make them visible/invisible.

Tools provided by ArcMap allow you to explore the spatial data in different ways. If you do not see this toolbar in
your ArcMap window, click Customize->Toolbars->Tools to turn it on.


Turn on Major Roads, Province, and Water layers and turn off the rest of layers. Click Zoom in button
(first button on the toolbar) and hold down the left mouse button and drag a rectangle around Vancouver
Island. The display window will fit into this area. You can further zoom out in the same way OR by clicking
a place in the area.



Click the global button

(full extent), this will make all data layers fit into the display window.

Play around with these zoom buttons to see the changes and notice the effect of zoom on the scale.

7. Symbolization in ArcMap
ArcMap loads each data layer with a default symbol chosen randomly by the system. You can change the symbol
to make the map more meaningful and readable.






UNBC

Make sure Major Roads, Railways, Provincial Park, National Park and Water layers are on. Turn off the
rest of layers.
Look at the map in the display window, can you tell which one is major road and which one is railway? No,
as Major Roads and Railways have same symbology (purple lines)
Change the properties of these layers to make them look different. Click the line below the Major Roads,
the symbol selector window pops up allowing you to choose a symbol or set the properties of the symbol.
Click the Major Road symbol in symbol selector window and change the color to red by clicking the
dropdown arrow right to the Color in the Option box. Click OK to apply the changes.
The map layers are redrawn and the Major Roads layer turns to red.
Repeat the steps to change the Railways to Railroad symbol (use the default color).
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Change the Provincial Park to Green symbol (the one with an outline).
Change National Park to Green symbol. Change the Fill color to dark green by clicking the dropdown list
for Fill Color.
Turn on Major Cities, Province layers. Does your map look better?

8. Examine the attribute data
The power of GIS is it allows the attributes and the geographic or map information to be linked. In this section you
will learn about the structure of attribute table for a spatial dataset.
Attribute data describes and quantifies spatial features and sometime we call these information non-spatial data.
The information is stored in DBF file for shape file, INFO files in the ARC/INFO coverages and in internal or
external database management system (DBMS) tables.
Each spatial dataset is associated with an attribute table. Each spatial feature in the dataset is linked to a record in
the attribute table to provide more information on the feature. A unique ID is used to identify each feature.
Attribute data can be used to query, classify spatial data and perform spatial analysis.


Right-click Major Cities -> Open Attribute Table.

This table comes with several data fields. The FID is the feature ID that uniquely identifies each feature in the
dataset. The Shape field tells you the feature type (geometry). Look at fields NAME, PROV and CAPITAL. The
NAME field gives the city name, the PROV field indicates the province of the city located and the CAPITAL field
tells if the city is a capital. You can always add more data fields to describe the features.
Follow the same steps to examine Province dataset. Look at the SHAPE, NAME, POP1996 data fields. The value in
the SHAPE field is "polygon" which indicates this is a polygon feature class. The POP1996 field tells the total
population of each province at the year of 1996
Simply Query
Attributes can be used for data query. For example, find the province with population greater than one million.






Click Selection->Select by Attributes from the top menu bar. A window popped up allows you to build a
query using the attributes in the table
Set Province for Layer and ‘Create a new selection’ for Method.
Double click on "POP1996", single click on ‘>’ button and type in 1000000. Click OK. You should see all
polygons with population greater than one million are highlighted in cyan color.
Now right-click Province and choose Open Attribute Table. All the selected records (spatial features) are
also highlighted here.
The selection can be cleared by clicking the ‘Clear Selection’ button

Now make a selection on Major Cities to get all the capital cities
 In the Select By Attribute window, highlight CAPITAL from the filed list and click Get Unique Value button
to list all unique values from the CAPITAL filed
 Now build a query expression as the following:
" CAPITAL " = 'Y'

This will select all the capital cities
You can save the selected features into a new dataset. For example, save these selected features to a new dataset
capital_cities
 Make sure the selected features are highlighted. Right-click on Major Cities and choose Data->Export
Data.
 In the popped window, make sure to set ‘Selected Features’ to Export
UNBC
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For the Output feature class, click on the Open Folder button and navigate to your geog300\intro_gis
folder and give the file name capital_cities.shp.
Set the Save as Type to Shapefile and Click OK and OK again to export the selected features.
Click OK when prompted to add the exported data into ArcMap. The selected features are shown as a
separate layer. Clear the selection on Major Cities.

9. Data Frame Properties
Organizing layers into data frames
Layers in the table of contents are grouped in the data frame. In this map, there is only one data frame named
"Layers" which is the default. You can have more than one data frames in the table of contents where each data
frame contains the data for different project, topic and working area.
A data frame simply groups the layers that you want to display together. You always get a default data frame
when you create a new map; it's listed at the top of the table of contents as "Layers" by default, you can change
the name to a more meaningful word.
Examine the map file canada.mxd. There is only one data frame Layers with an icon of three stacked yellow
layers. Since the datasets contained in Layers data frame are all about Canada, so we can change the name of the
data frame to Canada.





Right-click on Layers data frame and choose Properties.
Click General tab, here you can rename the data frame, set map units, change the scale and etc.
Now type 'Canada' in the Name box. You can put some description in the Description box if you want.
Click OK to apply the changes. The name of the default data frame is changed to Canada.

10. Layout View
Layout view allows you to design the map layout, place ancillary information and produce the final map.
 Make sure all layers are on. Click global button (full extent) to bring all data layers into the display
window.
 Select View->Layout View from top menu to switch to Layout View.
 By default, ArcMap create a layout in a letter size (8.5 x 11). You can set the page layout by selecting FILE>PAGE SETUP. Change the Page Orientation to Landscape and click OK.
 The spatial datasets are displayed in the box with eight small handles (small squares located at each
corner and middle on each side). If it does not show, click anywhere inside the box to select the data
frame. The box with handles is the current active data frame and these handles allow you to move and
resize the data frame.
 Place the mouse cursor over a corner handle and drag to resize the data frame. Resize the data frame to
make it occupy major area of the page.
 You can move the data frame by holding the mouse button inside the box and drag to move. Try it.

11. Placing ancillary information
Map Title



UNBC

Click Customize->Tools->Toolbar from to menu bar and make sure the Draw toolbar is checked on. On the
Draw toolbar, click the big A button, click the location you want to place the map title and type in
"Canada". Hit Enter.
The font size looks small. Double click the text you just typed in to pop up the properties window. Click
Change Symbol button and change the font size to 24. Click OK. Click OK.
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In the same way, you can place your name and date at lower right corner using font size 12.

Map Legend
 Uncheck the check box beside the Water layer to turn it off.
 Now add a map legend to the right of the map. Click Insert->Legend from the top menu bar. The Legend
Wizard window pops up allowing you to set up the properties of a legend.
 Click Next buttons for all following wizard windows until you see the Finish button showing at bottom of
window. This means that you will take all default settings for legend properties.
 Click Finish button. A map legend shows up on the map and highlighted
 Move the legend by clicking and dragging it to the right of the map.
North Arrow


You can add a north arrow to a map. It is not suitable on this map because north varies.

Scale bar
The scale bar is critical for a map. It gives the ratio between map and real world distance.







Click Insert -> Scale bar. Click Scale Line 1 from the selector window to select it.
Click the Properties button to open the Properties window.
Under Scale and Units tab, change the Number of division to 2, the Number of subdivisions to 1 and Units
to Kilometers
Click the dropdown list for ‘When resizing....’ and choose Adjust width. Set the Division value to 1000km
(the first text box at top).
Under Scale and Units tab, change the Label Position to “Below Center” from the dropdown list and click
OK. Click Ok again.
Move the scale bar above your name.

12. Saving the map file and Logout





You can save a local copy of this map file under your local directory. Select FILE->SAVE AS. Navigate to
K:\geog300\intro_gis\ and save the file as intro_gis .mxd.
Click File->Exit from ArcMap and ArcCatalog.
Click Start->Logoff. Click Log Off to logout from Terminal Server.
Click the System->Quit->Logout on the menu bar located at top in Linux window to logout from current
session.

Assignment 1: Canadian Cartography due next week lab session (sept 18,19,20)






UNBC

You will produce a presentable map of a subject of your choice, including one thematic layer (e.g. fire
perimeters symbolized by human/lightning start) and three or more contextual layers (e.g. roads, rivers,
towns), using the .mxd file you explored earlier. The purpose of this assignment is to become familiar with
the process of exporting maps from ArcGIS and combining those exports in PDF format.
What you see in “layout view” is only a preview, and it takes some trial and error to produce a map that
looks the way you really want. You will produce a series of three or more maps, each showing progressive
improvement towards the end goal of an attractive map communicating a particular point.
To begin, open Canada.mxd as before and go to layout view (View>layout view). If the “portrait” page
orientation is not appropriate for the subject of the map, use the “Change Layout” tool to select “Letter
(ANSI A) Landscape” for an 8.5 X 11” page size in landscape orientation.
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1. Select the layers you want to display on your map; turn these on and place them in a logical drawing
order (e.g. streams drawn above fire polygons = streams above fire polygons in the table of contents).
2. Examine the attribute tables of the layers you have selected and find something interesting to show
on the map (e.g. fire locations between 1950 and 1965, started by humans).
3. Symbolize the layers according to their purpose (see Section 9 of introduction lab)
4. Add a concise but descriptive title, a legend showing the meaning of the colors in the thematic layer,
and a scale bar.
5. Export as a PNG image at 300 DPI (File>export map>save as type PNG), saving to your K: drive.
6. Open the exported PNG file and examine the output. Note issues such as poor placement of ancillary
information, boundary lines too thin or too thick, colors with poor contrast, etc. Review with your TA
if possible. Make modifications, repeat steps 5 and 6 at least once, producing a minimum of three
outputs, each better than the last.

Deliverable: Make a title page with the course name, assignment number, your lab session, your name and
studentID. Import all PNG images into a Word document. Write a memo (one page, 150-300 words)
describing the location of the map, the information being communicated, and the items you
changed between editions of the map. Save as a PDF with the naming convention
lastname_firstname_geog3002018_A1.pdf. Email the file to your TA with subject Geog300 A1. You
are encouraged to begin this assignment during class and review your first outputs with your TA.

NOTE:

Please name the file correctly (lastname_firstname_geog3002018_A1.pdf).
Assignment is due next week lab session (Sept 18, 19, 20)
NO late assignment is accepted

Some sources of data for those wanting to go above and beyond:
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Canada: https://www.mcgill.ca/library/find/maps/geospatial-online
BC: https://catalogue.data.gov.bc.ca/dataset
Alberta: https://geodiscover.alberta.ca/geoportal/catalog/main/home.page
Saskatchewan: https://www.isc.ca/Pages/Content%20Gallery/GeoSask.aspx
Manitoba: http://www.manitoba.ca/iem/geo/gis/index.html
Ontario: https://www.ontario.ca/page/land-information-ontario
New Brunswick: http://www.snb.ca/geonb1/e/DC/catalogue-E.asp
Nova Scotia: https://geonova.novascotia.ca/
Quebec: https://www.mcgill.ca/library/find/maps (Gov’t data in a non-ESRI format)
Yukon: http://www.geomaticsyukon.ca/
Northwest Territories: http://www.geomatics.gov.nt.ca/dldsoptions.aspx (must register)
Nunavut: http://ntilands.tunngavik.com/maps/
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